After initial synchronization get error: Connection Error

I always get this result. I have tried WSUS with Server 2016 and 2019. I have tried WSUS with VMs and on individual computers. But always with the same result. I would really appreciate some help. Thank you.

John Anderson

Hi @john.anderson

There might be many reasons why we see that message. It seems like the mmc can’t connect to the local server. I see that you posted that in any deployment you have done you see the same no matter the OS or Infrastructure used.

Let me ask a couple of questions to troubleshoot the issue through all the configuration processes:
Did the initial synchronization work?
How’s the HDD space?
Can we try to disable the firewall to check if it is not an issue with the connection?
Is there any Group Policy that you believe might be an issue? a proxy?
Can you verify that the Update Services service, IIS, and SQL are running on the server?
Can you check the IIS console for any errors?

These are just things that come to mind when looking at the error message.