HyperV Connection

I’ve just installed a home lab network using HyperV. It is up and running at the monment. I was able to remote at home using another PC successfully. But When I was at work and attempted to remote in, I get this message (see image). What is the best way to approach this?

1 Like is your local address. You’ll likely need to use a VPN

1 Like

Exactly what @chance.m said. You need a VPN. I use OpenVPN to connect to my home lab. If you have an ASUS Router it may have it included with the router.


Or… (what I did) is forward the Port of incoming to the IP of your server. If you are able to enter and edit it in your Modem/Router. That will cost you nothing.

Must say that my configuration is little different because I got a old Google Appliance Server. Dell 710 with 48GB in, on that I run my HyperV. Server called SpongeBob :smile: image

And I connect to my Server where HyperV is running on.

What I did is:

  • Get your IP of your internet connection. (when you are at home www.whatismyip.com)
    As example, in my case is that

You can forward any port number from the public (internet) to a local IP and Port number at your Home (local)

on your modem/router you need to find the Port Forwarding.
By default the port number for RDP is 3389, for security I changed it to a other port number.
(you can change that in de Regedit of your Server… remember, it work right away so your connection will then be lost). If you want to connect to different servers from the internet, you need to forward for each server a port.

Server01: Public: Forward to
Server02 Public: Forward to

So, the local port number is optional, but then you got it the same as your Internet connection. The incoming port number you can change that at (on the server)
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

For you, you need to forward port 3387 to
Remember! In your home you need then to connect to if you change the default RDP port. You can try also at home if that works by enter the internet IP and depending how you set up, with or without the portnumber.
Forwarding looks like:

So, even you can connect to my Windows Server 2019 on
For this lab it is all fine, in a live environment you must use a VPN connection.

Edit: For you, you need to forward port 3387 to That must be 3389 (default RDP port)

1 Like

This is the simpler solution. Just open port 3388 and only allow connections from your remote IP address.

OpenVPN is a good option when your remote IP address might change or you need more than one person to connect and their IPs might change. Also, with OpenVPN I get access to the entire network, not just the one target server and there is encryption.

But you need to weigh complexity of configuration when trying to decide if you should just open ports or setup a VPN solution like OpenVPN.

Do you install the OpenVPN on the HyperV machine or host? The more stupid questions I asked, the more I leaned. Thank you Gents!

1 Like

And other alternative is to use Team Viewer (with a set password on it) or Logmein.

But Team Viewer will limit your access time to 5 minutes if you are accessing your server at home on a commercial netwerk (work).

1 Like

I like TeamViewer but I woud like to be on a lot longer than 5 mins. After I installed OpenVPN, I still not able to connect to my home server. Just to be clear, installed server2016 on HyperV at home --I also installed OpenVPN on the host PC at home. I am currently at work and I also install OpenVPM on my work PC. OpeVP status says…connected. But when I dailed in to my server at home it still giving me same failed message? What could be the problem?


1 Like

What kind of router do you have? Is it capable of running OpenVPN for you? Post the model and we can look at it. That would be much less complicated than setting up your own OpenVPN VM.

Hey Paul,…I don’t think its teh router. My wife is using her employer VPN at home and it works fine. But…I get these info to you as soon as I get home today.

1 Like

Little remark my side:,

  • Your wife is using it the other way around, she is the client and need to connnect to a server at her work.
  • You want to connect to your resources (server) at your home, so that is the other way.

So, what you can try is forward UDP port 25000 to your server. I don’t know if you change this, the default port for OpenVPN is 1194,
If there is no config on your modem/router to do that.
I do need to test it out myself, never done anything with it but every request that well be send to your modem, the modem need to know where to deliver that package. althought I must say that data does been send and recieved If I look on your picture.

See it like you enter a building, you are inside but do not know where to go if you do not be pointed to a location in the building.

This reply is only what I can see you posting, maybe the log will give you some more information.

If you want to set of ports are open, putty is this a good tool to check it.

What you can check out:
ping your server (see what the result is)
Check the log of OpenVPN
If you got a laptop, try to connect to your mobile foon with hotspot (or PC and use your telephone as Modem, use the USB cable then) and try if get it working like that.


What @luuc.zandbergen said. Your wife is connecting from your home network to your office. That is the opposite direction and is only one way.

Home > Work

You need:

Work > Home Lab


Any device with OpenVPN client installed > Home Lab

Bottom line is you need a server set up at home. The easiest way to do this is if your home router supports OpenVPN. If not, you can create an OpenVPN server in your Hyper-V environment. Or you could use a VPN remote access service like LogMeIn.

1 Like

I have forward UDP port 25000 to on my server and I have’t change anything on server or router. If default port for OpenVPN is 1194, does this mean I need to change port 1194 on OpenVPN side, I will give it a shot at it, will let you know how it turned out. Thanks!

1 Like

Its more like Work >Home lab. I haven’t change anything on my home router or OpenVPN on both sides of my work PC and Home lab server. will let you know how it goes. you both gave me some good directions. Fingers crossed!

1 Like

Ok. Yeah you definitely need to go from work > home lab. Nothing will work until you set up a VPN server either on your router or a VM. Let me know how it goes.