Promote Second Server

Paul, I am attempting to simulate the labs on my Dell R710–I’m on Lab Mod#2 (promoting 2nd server). I’m trying to promote this second server but I don’t think I set up the virtualbox correctly. I spent all

weekend troubleshooting this problem. All IP addresses setup on DC01 and DC02 are correct, but when I tried promoting the 2nd server it failed miserably. I am not getting the domain from the forest ( pop up window letting you know the domain has been found. After I provided the Administrator credential it failed with the message like you mentioned on your training videos. I think it’s the way I set up my virtualBox as a Bridged Adaptor. I have tried NAT Network and it failed to connect. I’m not sure what else I can do at this point. Please take a look at my setup. I supplied you some images, and please look at the second image (multiple IP addresses) in the attachment. I’m not sure what’s that all about. Thanks!

VirtualBox: using Bridged Adaptor
Domain name:

VirtualBox: using Bridged Adaptor
DC02 (2nd server)


1 Like

Change from a bridged network adapter to a NAT Network unless you need your other computers on the same network to access the VMs.

Make sure they are on the same NAT Network. Also try running “nslookup” from command prompt and see what you get back. Please post the results here.

Finally, if you purchased a physicall Dell PowerEdge server, you may want to consider running your environment on Hyper-V instead of VirtualBox. But I would make the switch after you get this working.

1 Like

Success! I had to blow out all my settings in VirtualBox. I also deleted all Host-Only Network and other Nat network I setup prior. I now have DC01 and DC02 IP address as listed. I changed to x.x.1.10 because I just found out that my home network is using this subnet. Go figure!!


DC02- Promoted
…but what are those extra IP addresses in circle is all about?
NAT Network Only

1 Like

This means you have multiple IP address in your DNS for Please check in your DNS console for duplicate records on both DC01 and DC02. If you find the entries that points to or, you can remove them or point them to the correct IP.

You should notice that in the second server you left out the [ . ] seperation between the numbers,

Yep I saw that but I knew what he meant. All good :+1:t2:

1 Like

Paul, I am attempting to promote the second DC in Lab 2 and I am getting the same exact error message in the Sandbox server: "An Active Directory domain controller for the domain “” could not be contacted. I have closed out this lab and re-run it mutiple times and still get the same error. What might I be doing wrong??

Hi @patricia.r.keith

Check the DNS IP address of the second DC, it should be the first DC IP address.


Hi Ricardo,

Thank you so much. I can only run the labs at home and when I got to work today, I was re-watching the videos here and wondered if I’d put in the wrong DNS address. Thank you for validating my thinking!